جلوگیری از حملات بروت فورس بر روی میکروتیک

در ادامه آموزش‌های تخصصی میکروتیک در این مطلب قصد داریم با موضوع جلوگیری از حملات بروت فورس بر روی میکروتیک درخدمت شما دوستان گرامی باشیم. Bruteforce یک ....

جلوگیری از حملات بروت فورس بر روی میکروتیک

حملات بروت فورس یکی از نام آشناترین حملاتی است که هکرهای حرفه‌ای و مبتدی برای ورود و نفوذ به سیستم‌ها انجام می‌دهند و میکروتیک نیز به عنوان یک روتر که قدرت بالایی در کنترل شبکه شما دارد از این قاعده نیز مستثنی نیست. بنابراین در این مطلب از سری مطالب آموزش میکروتیک قصد داریم شما را با آموزش جلوگیری از حملات بروت فورس بر روی میکروتیک آشنا سازیم تا برای همیشه از بروت فورس شدن راحت شوید.

بروت فورس در میکروتیک بیشتر بر روی پروتکل SSH و FTP انجام می‌گیرد و این دو سرویس هستند که بیشترین درگیری را در این نوع حملات دارند و البته نفوذ و در دست گرفتن هر یک از آنها توسط هکر ، به معنای از دست دادن روتر شما می‌باشد.

ما برای جلوگیری از حملات بروت فورس ، از یک سری رول در فایروال استفاده خواهیم کرد ، که در پایان به ما این امکان را خواهد داد که آدرس IP تمام افرادی که اقدام به بروت فورس می‌کنند را در لیستی قرار داده و آن لیست نیز توسط رول دیگر در فایروال به کلی بلاک می‌گردد.

با آموزش جلوگیری از حملات بروت فورس بر روی میکروتیک همراه ما باشید.

جلوگیری از حملات بروت فورس بر روی میکروتیک

1- ابتدا یک محیط ترمینال از داخل Winbox یا از طریق SSH باز کنید.

2- سپس دستور زیر را وارد کنید تا به تنظیمات فایروال در ترمینال بروید.

/ip firewall filter

3- سپس سه دستور زیر را به ترتیب وارد کنید تا از بروت فورس بر روی FTP جلوگیری شود.

add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop \
comment="drop ftp brute forcers"

add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect" \
address-list=ftp_blacklist address-list-timeout=3h

پس از وارد کردن دستور بالا ، میکروتیک اجازه وارد کردن 10 بار درخواست لاگین را در دقیقه به یک IP خواهد داد و پس از وارد کردن اشتباه اطلاعات لاگین ، تمامی درخواست‌های آن آدرس IP را DROP می‌کند.

4- حال برای جلوگیری از بروت فورس SSH میکروتیک خود می‌توانید دستورات زیر را وارد نمایید.

add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop \
comment="drop ssh brute forcers" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist \
address-list-timeout=10d comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 \
address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 \
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list \
address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no

5- پس از وارد کردن دستورات بالا ، دستور زیر را وارد کرده تا پس از این هر شخص شروع به ارسال درخواست‌های لاگین زیادی بر روی SSH داشت ، DROP شود.

add chain=forward protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop \
comment="drop ssh brute downstream" disabled=no

بدین ترتیب شما موفق به جلوگیری از حملات بروت فورس بر روی میکروتیک شده‌اید و از این پس ، حملات بروت فورس بر روی میکروتیک شما تأثیری نخواهد داشت.

نکته : به طور کلی هکرها برای نفوذ به میکروتیک از هر دو حالت بروت فورس بر روی FTP و SSH استفاده می‌کنند ، بنابراین پیشنهاد می‌نماییم دستورات جلوگیری از حملات بروت فورس بر روی FTP و SSH را همزمان با هم وارد کنید.

نکته مهم : چنانچه شما از سرویس SSH و FTP به طور کلی استفاده نمی‌کنید ، می‌توانید آنها را متوقف کرده تا از تمامی حملات بر روی این دو سرویس در امان بمانید.

امیدواریم در پایان ، آموزش جلوگیری از حملات بروت فورس بر روی میکروتیک برای شما مفید واقع شده باشد.

در آموزش بعدی به نحوه تنظیم سرویس‌های میکروتیک خواهیم پرداخت.

کاربر گرامی شما میتوانید سؤالات مربوط به این آموزش را در بخش کامنت‌ها عنوان کرده و در همین قسمت پاسخ خود را دریافت کنید.

نظرات کاربران


 
در حال بارگذاری...

برای مشاهده مطالب بیشتر به آکادمی آذرآنلاین مراجعه کنید

محتوای بیشتری برای بارگذاری وجود ندارید